Ich habe ein Problem mit easy_install für matplotlib-venn. Ich bin auf einem Windows-Computer mit Python2.7. Ich vermute, dass der Pfad nicht korrekt ist, aber ich weiß nicht, wie ich das Problem beheben kann. Könnte mir jemand helfen? Ich hänge die Ausgabe von dem Versuch an, den Befehl easy_install in der CMD-Eingabeaufforderung auszuführen.

C:\Python27\Scripts>easy_install matplotlib-venn
Searching for matplotlib-venn
Reading https://pypi.python.org/simple/matplotlib-venn/
Download error on https://pypi.python.org/simple/matplotlib-venn/: [Errno 11004]
 getaddrinfo failed -- Some packages may not be found!
Couldn't find index page for 'matplotlib-venn' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
Download error on https://pypi.python.org/simple/: [Errno 11004] getaddrinfo fai
led -- Some packages may not be found!
No local packages or download links found for matplotlib-venn
error: Could not find suitable distribution for Requirement.parse('matplotlib-ve
nn')
install for matplotlib-venn package

Ausgabe des Versuchs des Pip-Installationsvorschlags:

C:\Python27\Scripts>easy_install pip
Searching for pip
Best match: pip 1.4.1
Adding pip 1.4.1 to easy-install.pth file
Installing pip-script.py script to C:\Python27\Scripts
Installing pip.exe script to C:\Python27\Scripts
Installing pip.exe.manifest script to C:\Python27\Scripts
Installing pip-2.7-script.py script to C:\Python27\Scripts
Installing pip-2.7.exe script to C:\Python27\Scripts
Installing pip-2.7.exe.manifest script to C:\Python27\Scripts
Using c:\python27\lib\site-packages
Processing dependencies for pip
Finished processing dependencies for pip
C:\Python27\Scripts>pip install matplotlib-venn
Downloading/unpacking matplotlib-venn
  Cannot fetch index base URL https://pypi.python.org/simple/
  Could not find any downloads that satisfy the requirement matplotlib-venn
Cleaning up...
No distributions at all found for matplotlib-venn
Storing complete log in C:\Users\jherman8\pip\pip.log
8
jonas 26 Nov. 2013 im 18:21

3 Antworten

Beste Antwort

Beyogen auf

Download error on https://pypi.python.org/simple/matplotlib-venn/: [Errno 11004] getaddrinfo failed 

Und

Cannot fetch index base URL https://pypi.python.org/simple/ 

Es scheint, dass Sie ein Netzwerkproblem haben. Führen Sie Ihren Computer hinter einer Firewall oder einem Proxy aus?

Damit easy_install hinter dem Proxy funktioniert, müssen Sie beispielsweise die erforderlichen Umgebungen einrichten

set http_proxy="user:password@server:port"
set https_proxy="user:password@server:port"

Für pip können Sie das Argument -proxy verwenden. Weitere Details zur Pip-Verwendung hinter dem Proxy finden Sie in diesem Thread: Verwendung von Pip unter Windows hinter einem authentifizierenden Proxy

18
Community 23 Mai 2017 im 12:25

Ich denke das ist deine Lösung

easy_install pip
pip install matplotlib-venn

Kein Modul matplotlib-venn in easy_install

Und für die Zukunft verwenden Sie pip, um ein beliebiges Paket für Python zu installieren.

2
itdxer 26 Nov. 2013 im 14:25
student@student-WIV68105-0080:~$ **sudo apt-cache search rtree**
libcneartree-dev - Library and headers for solving the Nearest Neighbor Problem
libcneartree5 - Library for solving the Nearest Neighbor Problem
student@student-WIV68105-0080:~$ **sudo apt-get install libcneartree-dev libcneartree5**
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libcvector2
The following NEW packages will be installed:
  libcneartree-dev libcneartree5 libcvector2

Bei mir trat der gleiche Fehler für das rtree-Paket auf, und ich führte die Cache-Suche durch und installierte die Liraries

0
Dmitriy 1 Feb. 2016 im 06:38