Ich versuche, das SciPy-Paket unter Red Hat Enterprise Linux Server Version 6.3 zu installieren. Es schlägt jedoch fehl.

Die Version von Python, die ich verwende, ist 2.6, scheint jedoch 2.4 zu erfordern. Gibt es eine andere Version von SciPy, die mit 2.6 kompatibel ist? Wenn 2.4 erforderlich ist, gibt es Vorschläge, wie Sie das erreichen können? Ich habe die Anweisungen auf der Python-Webseite befolgt, aber sie scheinen veraltet zu sein . Es erfordert auch f2py, was ich nicht sicher bin, wie ich es bekommen soll.

Anregungen für eine einfachere Installation? Ich habe die Anweisungen hier befolgt.

Vielen Dank!

0
user1253952 9 Okt. 2012 im 12:45

3 Antworten

Beste Antwort

Ich konnte dieses Problem lösen, indem ich die neueste Version von NumPy herunterlud (das Erstellen und Installieren der Version von der Quelle, da die im Red Hat-Paketmanager einige Versionen veraltet war) und dann scipy installierte (über die Datei setup.py scipy I. heruntergeladen hatte).

2
user1253952 11 Okt. 2012 im 02:58

Aktivieren Sie das EPEL-Repository: https://fedoraproject.org/wiki/EPEL

Danach einfach "yum install scipy"

2
janneb 9 Okt. 2012 im 08:55

Ein Problem, auf das ich bei der Installation von SciPy aus setup.py auf RHEL 5 gestoßen bin, waren undefinierte _gfortran-Symbole.

Ich fand heraus, dass dies auf eine Nichtübereinstimmung im verwendeten FORTRAN-Compiler zurückzuführen ist. Ich hatte den gfortran-Compiler zum Erstellen der ATLAS / BLAS-Bibliotheken verwendet, verwendete jedoch den g77-Compiler zum Erstellen von SciPy

Wenn Sie dieses Problem haben, beheben Sie es, indem Sie die FORTRAN-Version angeben, die für das Setup verwendet werden soll. In meinem Fall, um den Gfortran-Compiler zu verwenden:

python setup.py build --fcompiler=gnu95 --force

Das Flag --force war erforderlich, um den Build mit dem falschen Compiler zu korrigieren.

Um Ihre verfügbaren FORTRAN-Compiler aufzulisten, verwenden Sie:

python setup.py build --help-fcompiler

Danach,

python setup.py install

Wie gewöhnlich.

0
Jesuisme 24 Okt. 2012 im 15:18