In Sitecore 7.2 gibt das Öffnen von FormDesigner den folgenden Fehler aus:

Exception: System.InvalidOperationException
Message: Handle not found.
Source: Sitecore.Kernel
   at Sitecore.Web.UrlHandle.Get(UrlString urlString, String handleName, Boolean removeSessionValue)
   at Sitecore.Form.Core.Utility.Utils.GetDataSource(String url) in C:\Users\Raymond.Weng\AppData\Local\JetBrains\Shared\v01\DecompilerCache\decompiler\DA67A299-0E6A-4A9B-A8E1-031DAB1327EB\e6\7823a5d7\Utils.cs:line 219
   at Sitecore.Forms.Shell.UI.FormDesigner.GetCurrentItem() in C:\Users\Raymond.Weng\AppData\Local\JetBrains\Shared\v01\DecompilerCache\decompiler\DA67A299-0E6A-4A9B-A8E1-031DAB1327EB\a8\50ab1903\FormDesigner.cs:line 723
   at Sitecore.Forms.Shell.UI.FormDesigner.LoadControls() in C:\Users\Raymond.Weng\AppData\Local\JetBrains\Shared\v01\DecompilerCache\decompiler\DA67A299-0E6A-4A9B-A8E1-031DAB1327EB\a8\50ab1903\FormDesigner.cs:line 163
   at Sitecore.Forms.Shell.UI.FormDesigner.OnLoad(EventArgs e) in C:\Users\Raymond.Weng\AppData\Local\JetBrains\Shared\v01\DecompilerCache\decompiler\DA67A299-0E6A-4A9B-A8E1-031DAB1327EB\a8\50ab1903\FormDesigner.cs:line 128

Request information: 
Request URL: http://myurl/sitecore/shell/Applications/Modules/Web Forms for Marketers/Form Designer?xmlcontrol=Forms.FormDesigner 
Request path: /sitecore/shell/Applications/Modules/Web Forms for Marketers/Form Designer 
User host address: xxx.xxx.xxx.xxx 
User: sitecore\admin 
Is authenticated: True 
Authentication Type:  
Thread account name: NT AUTHORITY\NETWORK SERVICE 

Ich denke, dass etwas mit der Installation nicht stimmt, aber wenn ich die Instanz mit den WFFM-Installationsdateien vergleiche, kann ich nicht sehen, was fehlt. Nicht einmal sicher, was Handle Not Found bedeutet?

1
Ethan Schofer 31 Dez. 2015 im 21:13

2 Antworten

Beste Antwort

Dies kam letztendlich auf die URL an. Sitecore wurde so eingestellt, dass die Sprache automatisch in die URL eingefügt wird (dies ist eine Einstellung im Abschnitt linkManager der Webkonfiguration). WFFM hat das wirklich nicht gefallen. Als ich diese Einstellung änderte, war alles in Ordnung.

UPDATE

Ein Beispiel-Patch wäre:

<configuration xmlns:patch="http://www.sitecore.net/xmlconfig/">
<sitecore>
    <linkManager>
        <providers>
            <add name="sitecore">
                <patch:attribute name="languageEmbedding">never</patch:attribute>                   
            </add>
        </providers>
    </linkManager>
</sitecore>
1
Ethan Schofer 2 Feb. 2018 im 21:23

Fügen Sie Formulare aus dem Erfahrungseditor hinzu? Wenn ja, können Sie einer Seite tatsächlich ein Formular hinzufügen? Gibt es dabei Konsolenfehler?

Könnten Sie nach Konsolenfehlern suchen? Haben Sie Webformulare für Vermarkter in Sitecore neu installiert?

Charlie :)

0
Charlie Afford 4 Jän. 2016 im 07:37