Hallo allerseits, ich habe erfolglos versucht, npm auf meinem Unternehmens-PC zu konfigurieren und zu verwenden.

Ich habe Proxy, https-Proxy, strict-ssl false und Registry http://registry.npmjs.org festgelegt Der Proxy wurde wie folgt festgelegt: "http: // user: password @ proxy_ip: proxy: port" Wo das Passwort ein Sonderzeichen in Urlencode geschrieben hat.

npm config get proxy 

Gibt den Proxy mit den Anmeldeinformationen zurück, wie sie sein sollten.

Ich habe meinen npm-Cache geleert und es erneut versucht.

Kein Erfolg.

Irgendwelche Ideen, was kann das Problem sein?

6
AndiFB 18 Apr. 2018 im 17:15

4 Antworten

Beste Antwort

Wenn Sie sich hinter einem Unternehmens-Proxy befinden, müssen Sie normalerweise die Domain hinzufügen, in der Sie sich befinden. Angesichts der Tatsache, dass auch die Zeichen URL-codiert sein sollten, würde dies folgendermaßen aussehen:

https: // domain% 5Cusername: password @ proxy: port

7
lautit 18 Apr. 2018 im 16:27

Ich empfehle, diesen Artikel zu lesen, um den Proxy für npm zu konfigurieren. http://wil.boayue.com/ blog / 2013/06/14 / using-npm-hinter-einem-Proxy /

  • npm config set proxy http://proxy.company.com:proxyport

  • npm config set http-proxy http://proxy.company.com:proxyport

  • npm config set https-proxy http://proxy.company.com:proxyport

Hoffe das ist nützlich für dich!

6
Suhas Gavad 18 Apr. 2018 im 17:14

Wir sollten einen Proxy mit Benutzername und Passwort hinzufügen, um diesen Fehler zu vermeiden. Zum Beispiel:

  • Benutzername: admin
  • Passwort: admin123
  • Proxy: 172.10.3.21
  • Hafen: 3128

npm config set proxy http://admin:admin123@172.10.3.21:3128
npm config set https-proxy http://admin:admin123@172.10.3.21:3128
4
Willi Mentzel 28 Jän. 2020 im 10:19

Das Bearbeiten der .npmrc-Datei im Benutzerordner hat bei mir funktioniert. Ich habe die Proxy- und npm-Registrierung wie folgt festgelegt:

proxy=http://username:password@proxy:port/
https-proxy=http://username:password@proxy:port
registry=http://registry.npmjs.org/  

Hinweis: Bei Benutzernamen und Kennwörtern mit speziellen Zeichen müssen die Zeichen in der Proxy-Konfiguration codiert werden. Wenn der Benutzername beispielsweise "Benutzer" und das Kennwort "1234 @ Benutzer" lautet, sieht die .npmrc-Datei folgendermaßen aus:

proxy=http://user:1234%40user@proxy:port/
https-proxy=http://user:1234@user@proxy:port
registry=http://registry.npmjs.org/ 

Dabei ist% 40 die codierte Form von "@". In meinem Fall wurde das Pfund-Symbol (#) im Benutzernamen oder Passwort nicht akzeptiert (weiß nicht warum).

1
Vishnu C Mohan 6 Nov. 2019 im 05:00