Mein Android Studio gibt mir einen Fehler, siehe Bilder unten

enter image description here

enter image description here

Aber Firebase Doc hat mir eine andere Version vieler Bibliotheken gegeben, hier ist das Dokument

enter image description here

Meine Frage ist also, ob Firebase Doc mir diese andere Version von Bibliotheken gibt. Warum gibt mir Android Studio diesen Fehler?

0
Bhavesh Rangani 23 Juni 2018 im 08:24

3 Antworten

Beste Antwort

Gemäß einem der vorgeschlagenen Kommentare hat das Aktualisieren einer Android Studio- und Gradle-Version mein Problem gelöst. Zuvor habe ich Android Studio 3.0 verwendet und nach dem Upgrade auf Android Studio 3.1.3 war dieser Fehler behoben.

Nachfolgend sind die Änderungen aufgeführt, die ich vorgenommen habe.

Android Studio wurde von 3.0 auf 3.1.3 aktualisiert

Gradle-Version auf 4.4 aktualisiert

Wenn sich Ihr Problem dadurch nicht beheben lässt, versuchen Sie, Ihre Google-Plugin-Version auf die neueste Version zu aktualisieren

Klassenpfad 'com.google.gms: google-services: latest.version'

0
Bhavesh Rangani 13 Juli 2018 im 10:46

Aktualisieren Sie die Version der Version des Gradle-Plugins für Google Services auf die neueste Version von build.gradle auf oberster Ebene:

classpath 'com.google.gms:google-services:4.0.1'

Dies ist das Plugin, das nach korrekten Versionen sucht. Nur neuere Versionen dieses Plugins verstehen das neue Versionssystem der Bibliotheken.

1
Doug Stevenson 23 Juni 2018 im 05:39

Verwenden Sie das folgende Google Service Plugin:

classpath 'com.google.gms:google-services:4.0.1'

Und Upgrade Firebase lädt ein:

implementation 'com.google.firebase:firebase-invites:16.0.1'
1
Peter Haddad 23 Juni 2018 im 07:51